phpunit

PHPUnit and CodeIgniter 3.0

PHPUnit and CodeIgniter 3.0

Quick tutorial how to setup proper unit testing with PHPUnit and CodeIgniter 3.0. We need couple elements CodeIgniter – we are working with version 3.0rc3 PHPUnit – latest one If you don’t have phpunit installed globally, you can go with composer, just add section to your composer.json { "require-dev": { "phpunit/phpunit": "4.1.*" } } and then composer.phar install and after while we have ./vendor/bin/phpunit working phpunit.